Application performance degradation
Incident Report for Lambda Labs GPU Cloud
Resolved
This incident has been resolved.
Posted Jun 11, 2024 - 14:24 PDT
Investigating
We are currently experiencing intermittent performance degradation for our on-demand dashboard and external API.
Posted Jun 11, 2024 - 11:29 PDT
This incident affected: Frontend (Website).