Network outage in Utah
Incident Report for Lambda Labs GPU Cloud
Resolved
This incident has been resolved. Cloud is now working as expected.
Posted Jun 22, 2023 - 13:21 PDT
Investigating
We are investigating an incident with our cloud. Our engineers are actively working to identify the root cause of the issue.
Posted Jun 22, 2023 - 12:11 PDT
This incident affected: Infrastructure (Network).